Welcome to OBD2Express.co.uk! Sign In or Register
Home - Products - Technical Service - Automobile Sensor Signal Simulation Tool MST-9000 instruction and faq
« Go Back

Automobile Sensor Signal Simulation Tool MST-9000 instruction and faq

Matched Product
Automobile Sensor Signal Simulation Tool MST-9000 MST-9000+

Automobile Sensor Signal Simulation Tool MST-9000 MST-9000+   Item No. SP98

Buy it Now: €499.00      Click Here to Shop
Automobile Sensor Signal Simulation Tool / 2012 Sensor Signal Simulation Experts-Golden version MST-9000
New update version:2012 MST-9000+
OBD2express.co.uk provides it with high quality, one-year warranty and unlimited technical service.


Automobile Sensor Signal Simulation Tool MST-9000 free download.
Automobile Sensor Signal Simulation Tool MST-9000 FAQ:

Q: I have purchased a MST-9000 and have been trying to use it and screen display has locked up to a solid blue (no text). Initial use was fine, the wakeup with power on to a splash screen, the menu worked and buttons responded. Power on/off a few times and no issue. The SW was loaded to computer (XP OS per instructions) and the SW loaded fine. Drivers for the MST-9000 USB connection were found through connection, manual find and all was OK.  An initial waveform was loaded to the ECU software, saved to the disk. After connection of USB from MST-9000+ to the computer as stated above the MST-9000 is locked as shown in pictures below. Only the on, off and read buttons have any effect now. The on is on, off is off, out and read beep at me, but read turns on CH1-5. Also the 5V, 12V, and 24V buttons activate lights, gages work too for Volts, etc.

Is there some reset or return to default condition on this MST-9000. I have read the manuals with the CD(PDF’s) but don’t see a way to restart in initial condition. Or a SW setting in the ECU software that allows the reset, etc.


I tried to power up the MST-9000 and its doing the same issue for the display today. Please reply with a status of your recommeneded fix or resolution. If you need any other information on button press/hold or a sequence of buttons,etc. to unlock or get a status of this instrument let me know.

A: Please check the power + – whether connected right?

Q: I tried this on four plugs at my bench (computer, monitor, Voltmeter HP3478A, and the MST-9000). All work fine, but the MST-9000 is same issue of solid lighted display. No splash screen or transition on startup visible (I looked). Tried on same plug I initially used it for first power on/off’s. Same issue is present now.

With this MST-9000 plugged in and on I get a tone(whine) of higher frequency that is like a driver or display upcoverter to operate the display(commonly used to have flicker free perception of the displays and backlighting shown on this LCD). Whine is only present with the LCD light, not the 0.3 sec transition of the lights off on rest of MST-9000.

Yes I am an engineer and try to observe critically what happened (used to this from work). Please reply with a next step or how to resolve this issue. Really want to try this MST-9000 out as an engine simulator. Thanks.

A: Does the light flashing after you connect power?

Q: No lights on or anything happens(lights, sound or anything I can detect), until the on button is pressed. Then a solid lamp backlit on the LCD display, no transition of the light, display or change unless its so fast I cannot detect it. Tried at angles for twist of these displays and no change or “hidden” letters I can detect off angle(left, Right, up, down, etc.)

A: Engineer ask you change a crystal oscillator next to the Main board CPU. Can you do this?

Q: I have opened up the case and looked over the board and parts with a technician at the office.  All the functions of power supplies, outputs to board for power, operations of the rotary knobs (pots, voltage dividers, etc.) are correct from what we saw and measured. The display was stuck in the lighted position and I had found the processor and crystal.  Tried to press,  touch for heat and no change on the operation. (Picture photo.jpg above of the uP and crystal) After a few tries the technician used electronics cooling freeze and cooled the processor and crystal.  This had the unit recover function of display to menu and a beep of speaker. All was OK and good. Worked with it for a few minutes to see if the heat of operation would cause the failure again. Did not fail quickly so he used a hot air gun(controlled temp on very low setting) and tried to heat up a bit. A few increments up to the roughly 70-90 deg c by feel of hand and it failed in same way again. Then cooled the crystal down and back to operation. So we believe it's the crystal as you had indicated. The CD you provided has many PDF's and I have searched this but don.t find a crystal oscillator spec sheet. The code on the crystal says 11.0592, I can find these easily in NA market with the leaded type used. A supplier of Newark Electronics has several available below to order

Can you provide the specific frequency tolerance, load capacitance, frequency stability and dimension for spacing on this part(4.0 or 4.06 mm). Or can you ship some of the crystals used and will change this here. We can likely change this here as its wire lead part.


A: I have talked with engineer, he said as long as it is 11.0592 crystal then it is all ok. Same size as the one you see, and he said no need those data you asked for, just common one is ok, but need it is 11.0592 frequency.

Q: I have the crystals on order with Newark Electronics and will receive them middle of week.  Then try to swap the crystal and do a burn in(operate for hours of about 10-12) and see that this works adequately.


Write a Review
* Rating:
    Please select rating stars.
* Your First & Last Name:
* Your E-Mail Address:
* Review Detail:
*Verification Code:
          No right? Get a new Verification Code
Tell us what you think about this item and share your opinions with other people. Please make sure your review focuses only on this item. All reviews are moderated and will be reviewed within two business days. Inappropriate reviews will not be posted.
After-sales questions and issues: Contact our Customer Service Department. (A customer representative will get back to you).
Please Sign In first if you want to later edit or manage reviews uploaded by yourself.


You can search Technical Service by keyword.
Bookmark It